Stack-based buffer overflow in Western Digital My Cloud allows for remote code execution

------------------------------------------------------------------------
Stack-based buffer overflow in Western Digital My Cloud allows for
remote code execution
------------------------------------------------------------------------
Remco Vermeulen, January 2017

------------------------------------------------------------------------
Abstract
------------------------------------------------------------------------
It was discovered that the Western Digital My Cloud is vulnerable to a
stack-based buffer overflow in the authentication mechanism. By
exploiting this vulnerability it is possible for an unauthenticated
attacker to run arbitrary code with root privileges.

------------------------------------------------------------------------
Tested versions
------------------------------------------------------------------------
This vulnerability was successfully verified on a Western Digital My
Cloud model WDBCTL0020HWT running firmware version 2.21.126. This issue
isnt limited to the model that was used to find this vulnerability
since most of the products in the My Cloud series share the same
(vulnerable) code.

------------------------------------------------------------------------
Fix
------------------------------------------------------------------------
There is currently no fix available.

------------------------------------------------------------------------
Details
------------------------------------------------------------------------
https://www.securify.nl/advisory/SFY20170105/stack_based_buffer_overflow_in_western_digital_my_cloud_allows_for_remote_code_execution.html