[ GLSA 200906-03 ] phpMyAdmin: Multiple vulnerabilities

--=-enw0qycX1QJgG22U2zXZ
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200906-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: phpMyAdmin: Multiple vulnerabilities
      Date: June 29, 2009
      Bugs: #263711
        ID: 200906-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

Multiple errors in phpMyAdmin might allow the remote execution of
arbitrary code or a Cross-Site Scripting attack.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

phpMyAdmin is a web-based management tool for MySQL databases.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/phpmyadmin     < 2.11.9.5                      >=3D 2.11.9.5

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Multiple vulnerabilities have been reported in phpMyAdmin:

* Greg Ose discovered that the setup script does not sanitize input
  properly, leading to the injection of arbitrary PHP code into the
  configuration file (CVE-2009-1151).

* Manuel Lopez Gallego and Santiago Rodriguez Collazo reported that
  data from cookies used in the "Export" page is not properly sanitized
  (CVE-2009-1150).

Impact
=3D=3D=3D=3D=3D=3D

A remote unauthorized attacker could exploit the first vulnerability to
execute arbitrary code with the privileges of the user running
phpMyAdmin and conduct Cross-Site Scripting attacks using the second
vulnerability.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Removing the "scripts/setup.php" file protects you from CVE-2009-1151.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All phpMyAdmin users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Ddev-db/phpmyadmin-2.11.9.5"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2009-1150
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-1150
  [ 2 ] CVE-2009-1151
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-1151

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200906-03.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--=-enw0qycX1QJgG22U2zXZ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iEYEABECAAYFAkpJQqwACgkQk+oqhfPAZGlGFwCfeMGSCDV4Ko7H1rvIk5f+rWb/
TcoAoI0+MVLUp3gnhlG1nRRmLf1BEIpX
=vke4
-----END PGP SIGNATURE-----

--=-enw0qycX1QJgG22U2zXZ--