[ GLSA 200907-01 ] libwmf: User-assisted execution of arbitrary code

--=-gKTwVFADouHQo26IFqkp
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: libwmf: User-assisted execution of arbitrary code
      Date: July 02, 2009
      Bugs: #268161
        ID: 200907-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

libwmf bundles an old GD version which contains a "use-after-free"
vulnerability.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

libwmf is a library for converting WMF files.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

    -------------------------------------------------------------------
     Package            /   Vulnerable   /                  Unaffected
    -------------------------------------------------------------------
  1  media-libs/libwmf     < 0.2.8.4-r3                  >=3D 0.2.8.4-r3

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

The embedded fork of the GD library introduced a "use-after-free"
vulnerability in a modification which is specific to libwmf.

Impact
=3D=3D=3D=3D=3D=3D

A remote attacker could entice a user to open a specially crafted WMF
file, possibly resulting in the execution of arbitrary code with the
privileges of the user running the application, or a Denial of Service.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All libwmf users should upgrade to the latest version which no longer
builds the GD library:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=3Dmedia-libs/libwmf-0.2.8.4-r3"

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

  [ 1 ] CVE-2009-1364
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2009-1364

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-01.xml

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--=-gKTwVFADouHQo26IFqkp
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iEYEABECAAYFAkpNDFkACgkQk+oqhfPAZGk6JACcD2e3ZNyYVos7R8PAzm7pnIIl
G94An14epnUDayUY0y1qNlBOhoIV5eyu
=KVhd
-----END PGP SIGNATURE-----

--=-gKTwVFADouHQo26IFqkp--