[ GLSA 200907-09 ] Cyrus-SASL: Execution of arbitrary code

--nextPart1981811.F407ItMYAH
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Cyrus-SASL: Execution of arbitrary code
      Date: July 12, 2009
      Bugs: #270261
        ID: 200907-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in Cyrus-SASL might allow for the execution of
arbitrary code in applications or daemons that authenticate using SASL.

Background
==========

Cyrus-SASL is an implementation of the Simple Authentication and
Security Layer.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /  Vulnerable  /                  Unaffected
    -------------------------------------------------------------------
  1  dev-libs/cyrus-sasl      < 2.1.23                       >= 2.1.23

Description
===========

James Ralston reported that in certain situations, Cyrus-SASL does not
properly terminate strings which can result in buffer overflows when
performing Base64 encoding.

Impact
======

A remote unauthenticated user might send specially crafted packets to a
daemon using Cyrus-SASL, possibly resulting in the execution of
arbitrary code with the privileges of the user running the daemon or a
Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Cyrus-SASL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/cyrus-sasl-2.1.23"

References
==========

  [ 1 ] CVE-2009-0688
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0688

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart1981811.F407ItMYAH
Content-Type: application/pgp-signature; name=signature.asc 
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iQIcBAABCAAGBQJKWiB/AAoJECaaHo/OfoM5hlMP+wW9/waLxPR1IQ6U59FLOMQ8
e0jIjMEIdP26R1sdPBPjaydXcDmXBVro0R5DZ3qnM376qXqGKpkAcQb78a+9NVGk
Qrl2dvBXzHS+Kxxr686VlF3n+XhHRQSB+15X4dxij16Ag1IYTf2/M2AKWgcLXvnf
nr5gdZXQM/nggG9OrMWgkpWWtOxY5sY0qZd3GYHE5nSkxqeJrH5qLIKvVEJa9YSs
FQJndY+FUZt9gam154c0yGRvnlCh65BeBhwx+XSiUjSnFYV4zrgIMdDWh5iq0aRv
vzezK6UbmZMYP7YARv0K7rMhk4ldpV9ReXvQhpF3r+RoXuIqerTZzlJ88g+y1rmE
xCGLS1gNujKaTVj0zxGQZ8d60rpp/sa5JmHwcAw4ghuUQdsAzNcpthHx9Dmstogy
6edbliC8NofiAZxH7qgKbCM1Rl7A/hEF0bDQrr2Ak4j2WTOC2xQlpWx1h4rtgaIU
Y6CZLGysoNEt1zcbrYv9yFYniN0QOySW7HPJ2jbzKQ3bzUrAEniRQyhOXmEfwSry
An9Q5ZK+F4duPVHw7R8TWB82TLx+YT2R2ZhiS2/GueEzH/MLxKqT9Eruw9/8attk
qmwKdramqr6gtYVVEnzj9cN/UkXrUqrIVTCxEA6AYLGFNfTORhRsujiu0rfmbali
Jwqo+ROFTUm5iAa52Rbp
=WAff
-----END PGP SIGNATURE-----

--nextPart1981811.F407ItMYAH--