[ GLSA 200907-13 ] PulseAudio: Local privilege escalation

--nextPart1550617.7ffAbpqmEe
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200907-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PulseAudio: Local privilege escalation
      Date: July 16, 2009
      Bugs: #276986
        ID: 200907-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in PulseAudio may allow a local user to execute code
with escalated privileges.

Background
==========

PulseAudio is a network-enabled sound server with an advanced plug-in
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package                 /   Vulnerable   /             Unaffected
    -------------------------------------------------------------------
  1  media-sound/pulseaudio      < 0.9.9-r54              >= 0.9.9-r54

Description
===========

Tavis Ormandy and Julien Tinnes of the Google Security Team discovered
that the pulseaudio binary is installed setuid root, and does not drop
privileges before re-executing itself. The vulnerability has
independently been reported to oCERT by Yorick Koster.

Impact
======

A local user who has write access to any directory on the file system
containing /usr/bin can exploit this vulnerability using a race
condition to execute arbitrary code with root privileges.

Workaround
==========

Ensure that the file system holding /usr/bin does not contain
directories that are writable for unprivileged users.

Resolution
==========

All PulseAudio users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot -v ">=media-sound/pulseaudio-0.9.9-r54"

References
==========

  [ 1 ] CVE-2009-1894
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1894

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200907-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart1550617.7ffAbpqmEe
Content-Type: application/pgp-signature; name=signature.asc 
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iQIcBAABCAAGBQJKXzcVAAoJECaaHo/OfoM5BYIQALWTGc3tL8EmtudRhf79AzxT
86pBUn2ZUTsyn7vTAn5KRJxS9wNbsu7pVGXuAD4UcIQ9DtfXHx7Q6j+bSfC/NFYu
Q1XrZIxZXWxb4LuoVE5ltyta5ayL/TlAFKXZ7M5QXYEVSOE/p3jUpseGtS8Qd/dS
nLBcauxxKALRwnwE5fN131UTpi+SdxdArHypJdr35YmW3Llb3vAd3BHTE41m5+7k
A2Pk6/Jd/jam5Otd+k3UyoIuSsArPSuf/9A1ET1gAUSaQMX3wnaK+PMbGEVkUunV
TyI3ui1f2yUusYMroc8/OgmnihiF+SK3WPZtXbwj105oFgrgDkoiWVI7UDuc6AMY
fNGF9L2F4dYvEtFuiAleG+EKgbxmYqM1xoMQt7D/ojrsIYA0aEuzkofnHEjMKGRe
OdutN0pwSo/8h7er3H5/uRAlTu2ugBP40MsXeV5pkEqkdiTmjUF1DG9mt3tSqVaK
hF6SY2ETQFyhse8dTv5xlg7w27tOMUArz7BcMuFlnJXy/TndVDg4nQD+Uur6ub00
zbPwVefK9uwA4ee1722G2a+Wl50hT90QXZOEciuj/pGZJp5A1H0BQxIFhKe84RG2
g5KPgxRhKDIrG/sDbVXdPD/sgid6MgfieSZb99cH7TKYYLl22vCYVPB49mWKvnht
kMh0Br1N6FD6J9BcS63v
=ygDr
-----END PGP SIGNATURE-----

--nextPart1550617.7ffAbpqmEe--